I suggest you ...

Fix custom domains

I was testing the custom domains but found they don't work as described. They're supposed to respond like domain.com/xxxx but you have to put an underscore before like domain.com/_/xxxx to reach your file.
Also, if you simply visit domain.com/, there should be either a redirect to a user set location or infinit homepage: you shouldn't load your home under user's domains 'cause SSL and things.

3 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Anatoli NicolaeAnatoli Nicolae shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    started  ·  InfinitAdminInfinit (Support, Infinit) responded  · 

    Our apps won’t be able to generate a link with your custom domain until the next update.

    Until then, you can follow these instructions to send links with your domain.

    Generate an Infinit link. It will look like https://infinit.io/_/XXXXXX

    Replace the beginning of your link with your domain and change https to http. It will look like this: http://domain.tld/_/XXXXXX or http://subdomain.domain.tld/_/XXXXXX

    Our next update will do this for your automatically.

    We’ll also be changing the redirect for your domain. I’m sorry that this is the case at the moment.

    5 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • InfinitAdminInfinit (Support, Infinit) commented  ·   ·  Flag as inappropriate

        Thanks for posting. HTTPS for links is in our pipeline, but it's not available just yet. However, when you generate a link and you've put in place a custom domain, the link generated should appear with HTTP and not HTTPS. If you're encountering such a problem, could you please send me an email at pat@infinit.io?

      • Philippe HabigandPhilippe Habigand commented  ·   ·  Flag as inappropriate

        Hello,
        Using custom domain for my account work as I manually remove https to put http.
        The SSL certificate is not available since the domain is not the same.
        Is it possible to generate a new certificate for our domain and put it on your server ?

      • InfinitAdminInfinit (Support, Infinit) commented  ·   ·  Flag as inappropriate

        We released this feature as a sort of preview and test to begin with. On Windows, this should now work correctly with the auto-link generation for custom domains in http. We'll be bringing this to Mac as well very shortly.

      • Anatoli NicolaeAnatoli Nicolae commented  ·   ·  Flag as inappropriate

        Yeah, I wasn't referring to app generated links. I was saying you're not handling custom domains correctly: you'd better put a custom service with just a small piece of your app that only does "get id, search db, show item" and doesn't point the custom domain to your servers IPs (causing https and other security flaws).

      • Pablo SmithPablo Smith commented  ·   ·  Flag as inappropriate

        I'm not even able to add a custom domain. Every time I click "add", it just redirects and nothing new shows up.

      Feedback and Knowledge Base